Managing Projects

A project is the basic unit used to create, run, and debug a vision workflow within a solution.

This section introduces common operations for projects in RVS 2.0.

Create New Project

You can create a new project in the currently opened solution in any of the following ways:

  • From the Home Screen Menu Bar

    Click “File” > “New Project” > “Create Vision Project” in the menu bar of the home screen.

  • From the Solution Context Menu

    In the Project List pane, right-click the solution name and select “New Project” > “Create Vision Project” from the context menu.

  • Using a Keyboard Shortcut

    Press Ctrl + N on the home screen.

Save Project

You can save a project in either of the following ways:

  • From the Project Programming Workspace Toolbar

    In the Project List pane, select the project to open it in the project programming workspace, then click the save icon () in the upper-left corner.

  • By Saving the Solution

    Saving a solution also saves all projects contained in it. For more, see Saving a Solution.

Open Project

Projects are bound to their parent solutions. You can open a project in either of the following ways:

  • By Opening the Parent Solution

    When you open a solution, all projects in that solution are loaded automatically.

  • From the Home Screen Menu Bar

    Click “File” > “Open Project” in the menu bar of the home screen. In the Open dialog, select the .VisionProject file in the target project folder and click “Open”. The parent solution is loaded automatically as well.

Rename Project

Right-click the project name in the Project List pane and select “Rename Project” from the context menu.

Close Project

Projects are bound to their parent solutions. Closing a solution also closes all projects in it. Opening another solution closes the projects of the current solution as well.

Run and Debug Project

Click the run icon () in the project programming workspace to run the current project.

If the execution result is not as expected, debug the project as follows:

  1. Locate the Abnormal Step

    Check the output and status of each step in sequence to find the step where the result first deviates from what is expected.

  2. Adjust Step Parameters

    For the step with the abnormal output, adjust its parameters to optimize the result.

  3. Check Execution Time

    After a step finishes running, its execution time is displayed in the lower-left corner of the step. Use this information as a reference when tuning project performance.

Delete Project

Right-click the project name in the Project List pane and select “Delete Project” from the context menu.

Duplicate Project

Right-click the project in the Project List pane and select “Duplicate Project” from the context menu.

Reset Project IDs

  • If deleting a project results in non-consecutive project IDs, right-click the solution name in the Project List pane and select “Reset Project IDs”.

  • To reorder projects, drag the target project to the desired position in the Project List pane, then right-click the solution name and select “Reset Project IDs”.